欢迎观临!TOU金融资讯网,本资站提供大量有关股票配资,期货配资,配资平台,配资服务,外汇配资,正规配资平台,配资公司,配资技巧资讯帮助股民在未来的日子实现财富飞跃!
当前位置:主页 > 股票公式 >

通信达公式指标大全 通达信最牛分时主图公式源码

来源:股票公式 作者:股票公式知识时间:2020-03-19 20:54        

通信达公式指标大全通达信最牛分时主图公式源码TOU金融网小编为您提供现将我近段时间,找到的最牛分时主图分享出来攻击量:=((HSL*0.50+REF(HSL,1)*0.33)+(REF(HSL,2)*0.17))*SUM(C,FROMOPEN)/FROMOPEN...

     通信达公式指标大全 通达信最牛分时主图公式源码 TOU金融网小编为您提供  

现将我近段时间,找到的最牛分时主图分享出来

攻击量:=((HSL*0.50+REF(HSL,1)*0.33)+(REF(HSL,2)*0.17))*SUM(C,FROMOPEN)/FROMOPEN;
攻击量A:=SUM(IF(C>REF(C,1),攻击量*V,0),FROMOPEN),COLOR0000FF,LINETHICK0;
攻击量B:=-SUM(IF(C<REF(C,1),攻击量*V,0),FROMOPEN),COLOR00FF00,LINETHICK0;
攻击流量:=攻击量A+攻击量B,COLORSTICK;
攻击比:=攻击流量/SUM(V,FROMOPEN)*100,COLORRED,LINETHICK1;
资金攻击度:=IF(攻击比>=0,(攻击比+50),100-ABS((攻击比-50)));
资金流入:=SUM(IF(C>REF(C,1),V,0),FROMOPEN),STICK,COLORRED;
资金流出:=-SUM(IF(C<REF(C,1),V,0),FROMOPEN),STICK,COLOR00FF00;
资金出入:=资金流入+资金流出,COLORSTICK;
资金比:=资金出入/SUM(V,FROMOPEN)*100,COLOR00FFFF,LINETHICK1;
资金流量比:=IF(资金比>=0,(资金比+100)/2,100-ABS((资金比-100)/2));
DRAWTEXT_FIX(1,0.250,0.88,0,STRCAT(STRCAT('【资金流量比】',CON2STR(资金流量比,2)),'%买')),COLORCYAN;
DRAWTEXT_FIX(1,0.000,0.88,0,STRCAT(STRCAT('【资金攻击度】',CON2STR(资金攻击度,2)),' %买')),COLORCYAN;

XG:HHV(H,480),DOTLINE,COLORRED;
STICKLINE(FILTER(CROSS(C,REF(XG,1)),10) AND C>REF(XG,1),C*0.99,C,8,0),COLORGREEN;
DRAWTEXT(FILTER(CROSS(C,REF(XG,1)),10) AND C>REF(XG,1),C*0.99,'突破'),COLORYELLOW;
RQ:=DATETODAY(DATE)-DATETODAY(REF(DATE,TOTALBARSCOUNT-CURRBARSCOUNT))+1;
JY:=BARSLAST((RQ-REF(RQ,1))!=WEEKDAY-REF(WEEKDAY,1) OR TOTALBARSCOUNT-CURRBARSCOUNT=0)+1;
MA1:=REF(C,JY);
MA2:=REF(MA1,JY);
MA3:=REF(MA2,JY);
MA4:=REF(MA3,JY);
MA5:=REF(MA4,JY);
MA6:=REF(MA5,JY);
MA7:=REF(MA6,JY);
MA8:=REF(MA7,JY);
MA9:=REF(MA8,JY);
CK:REFDATE((C+MA1+MA2+MA3+MA4+MA5+MA6+MA7+MA8+MA9)/10,DATE),COLORAC59FF,CIRCLEDOT;
DRAWTEXT(ISLASTBAR,CK,' 参考线'),COLOR0000FF;

DIF:=(EMA(CLOSE,12)-EMA(CLOSE,26))+DYNAINFO(3);
DEA:=EMA(DIF,9);
MACD1:=10*(DIF-DEA);
MACD2:=EMA(MACD1,2);
STICKLINE(MACD1>=MACD2 AND MACD1>=0,DYNAINFO(3),MACD1+DYNAINFO(3),0,0),COLOR0000B4;
STICKLINE(MACD1<MACD2 AND MACD1>0,DYNAINFO(3),MACD1+DYNAINFO(3),0,0),COLOR00B400;
STICKLINE(MACD1>=MACD2 AND MACD1<0,DYNAINFO(3),MACD1+DYNAINFO(3),0,0),COLOR5151A2;
STICKLINE(MACD1<MACD2 AND MACD1<0,DYNAINFO(3),MACD1+DYNAINFO(3),0,0),COLOR88743A;


XX:=SUM(AMOUNT,BAR

SCOUNT(CLOSE))/SUM(V*100,BARSCOUNT(CLOSE));
主力:=EXPMA(CLOSE/XX,20);大户:=EXPMA(CLOSE/XX,60);散户:=EXPMA(CLOSE/XX,120);
底:=1;1.02,NODRAW;高:=1.03;
DRAWTEXT(CROSS(主力,1.02),C*0.999,'-拉升'),COLORCYAN;
DRAWICON(CROSS(主力,1.04),C,24);
DRAWTEXT(CROSS(主力,1.04),C*0.999,'-冲涨停'),COLORLIMAGENTA;
A1:=(VOL/CLOSE)/3;
A2:=SUM((IF(((A1>40) AND (CLOSE>(REF(CLOSE,1)))),A1,0)),0);
A3:=SUM((IF(((A1>40) AND (CLOSE<(REF(CLOSE,1)))),A1,0)),0);
A4:=SUM((IF(((A1<40) AND (CLOSE>(REF(CLOSE,1)))),A1,0)),0);
A5:=SUM((IF(((A1<40) AND (CLOSE<(REF(CLOSE,1)))),A1,0)),0);
A6:=((A2+A3)+A4)+A5;
A7:=IF((BARSTATUS=2),((100*A2)/A6),0);
A8:=((IF((BARSTATUS=2),((100*A3)/A6),0)));
A9:=((IF((BARSTATUS=2),((100*A4)/A6),0)));
A10:=((IF((BARSTATUS=2),((100*A5)/A6),0)));
机构买盘:=(A2),LINETHICK2;
机构卖盘:=(A3),LINETHICK2;
散户买盘:=(A4);
散户卖盘:=(A5);
DRAWTEXT_FIX(1,0.000,1-0.05,0,STRCAT(STRCAT('【机构买盘】',CON2STR(机构买盘,2)),'万')),COLORRED;
DRAWTEXT_FIX(1,0.250,1-0.05,0,STRCAT(STRCAT('【机构卖盘】',CON2STR(机构卖盘,2)),'万')),COLOR00FF00;
DRAWTEXT_FIX(1,0.500,1-0.05,0,STRCAT(STRCAT('【散户买盘】',CON2STR(散户买盘,2)),'万')),COLORRED;
DRAWTEXT_FIX(1,0.745,1-0.05,0,STRCAT(STRCAT('【散户卖盘】',CON2STR(散户卖盘,2)),'万')),COLOR00FF00;
H1:=MAX(DYNAINFO(3),DYNAINFO(5));
L1:=MIN(DYNAINFO(3),DYNAINFO(6));
P1:=H1-L1;
阻力:=L1+P1*7/8,COLORGREEN;
支撑:=L1+P1*0.5/8,COLORMAGENTA;
DRAWTEXT(LONGCROSS(支撑,C,2),C,'买'),COLORYELLOW;
DRAWTEXT(LONGCROSS(C,阻力,2),C,'卖'),COLORGREEN;
量价:=(VOL/CLOSE)/3;
B2:=SUM((IF(((量价>0.20) AND (CLOSE>(REF(CLOSE,1)))),量价,0)),0);
B3:=SUM((IF(((量价>0.20) AND (CLOSE<(REF(CLOSE,1)))),量价,0)),0);
B6:=B2+B3;DD1:=1;比:=B2/B3;{www.buyhaogu.com} 
BBB1:=STRCAT(STRCAT('买= ',CON2STR((100*B2)/B6,0)),'%');
BBB2:=STRCAT(STRCAT('卖= ',CON2STR((100*B3)/B6,0)),'%');
BBB3:=STRCAT(STRCAT('差= ',CON2STR((100*(B2-B3))/B6,0)),'%');
DRAWTEXT_FIX(DD1=1,0,0.70,0,BBB1),COLORRED;
DRAWTEXT_FIX(DD1=1,0,0.75,0,BBB2),COLORGREEN;
DRAWTEXT_FIX(DD1=1,0,0.80,0,BBB3),COLOR00FFFF;

攻击量赋值:((换手线*0.50+1日前的换手线*0.33)+(2日前的换手线*0.17))*收盘价的当前离开盘分钟数日累和/当前离开盘分钟数
攻击量A赋值:如果收盘价>1日前的收盘价,返回攻击量*成交量(手),否则返回0的当前离开盘分钟数日累和,COLOR0000FF,线宽为0
攻击量B赋值:-如果收盘价<1日前的收盘价,返回攻击量*成交量(手),否则返回0的当前离开盘分钟数日累和,COLOR00FF00,线宽为0
攻击流量赋值:攻击量A+攻击量B,COLORSTICK
攻击比赋值:攻击流量/成交量(手)的当前离开盘分钟数日累和*100,画红色,线宽为1
资金攻击度赋值:如果攻击比>=0,返回(攻击比+50),否则返回100-(攻击比-50)的绝对值
资金流入赋值:如果收盘价>1日前的收盘价,返回成交量(手),否则返回0的当前离开盘分钟数日累和,STICK,画红色
资金流出赋值:-如果收盘价<1日前的收盘价,返回成交量(手),否则返回0的当前离开盘分钟数日累和,STICK,COLOR00FF00
资金出入赋值:资金流入+资金流出,COLORSTICK
资金比赋值:资金出入/成交量(手)的当前离开盘分钟数日累和*100,COLOR00FFFF,线宽为1
资金流量比赋值:如果资金比>=0,返回(资金比+100)/2,否则返回100-(资金比-100)/2的绝对值
当满足条件1时,在横轴0.250纵轴0.88位置书写文字,画青色
当满足条件1时,在横轴0.000纵轴0.88位置书写文字,画青色
输出XG:480日内最高价的最高值,DOTLINE,画红色
当满足条件收盘价上穿1日前的XG的10日过滤ANDC>1日前的XG时,在收盘价*0.99和收盘价位置之间画柱状线,宽度为8,0不为0则画空心柱.,画绿色
当满足条件收盘价上穿1日前的XG的10日过滤ANDC>1日前的XG时,在收盘价*0.99位置书写文字,画黄色
RQ赋值:日期对应的转换天数-总的周期数-到最后交易的周期日前的日期对应的转换天数+1
JY赋值:上次(RQ-1日前的RQ)不等于星期-1日前的星期ORTOTALBARSCOUNT-到最后交易的周期=0距今天数+1
MA1赋值:JY日前的收盘价
MA2赋值:JY日前的MA1
MA3赋值:JY日前的MA2
MA4赋值:JY日前的MA3
MA5赋值:JY日前的MA4
MA6赋值:JY日前的MA5
MA7赋值:JY日前的MA6
MA8赋值:JY日前的MA7
MA9赋值:JY日前的MA8
输出CK:日期日(收盘价+MA1+MA2+MA3+MA4+MA5+MA6+MA7+MA8+MA9)/10,COLORAC59FF,CIRCLEDOT
当满足条件是否最后一个周期时,在CK位置书写文字,COLOR0000FF
DIF赋值:(收盘价的12日指数移动平均-收盘价的26日指数移动平均)+前收盘价
DEA赋值:DIF的9日指数移动平均
MACD1赋值:10*(DIF-DEA)
MACD2赋值:MACD1的2日指数移动平均
当满足条件MACD1>=MACD2ANDMACD1>=0时,在前收盘价和MACD1+前收盘价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR0000B4
当满足条件MACD1<MACD2ANDMACD1>0时,在前收盘价和MACD1+前收盘价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR00B400
当满足条件MACD1>=MACD2ANDMACD1<0时,在前收盘价和MACD1+前收盘价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR5151A2
当满足条件MACD1<MACD2ANDMACD1<0时,在前收盘价和MACD1+前收盘价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR88743A
XX赋值:成交额(元)的收盘价的有效数据周期数日累和/成交量(手)*100的收盘价的有效数据周期数日累和
主力赋值:收盘价/XX的20日指数移动平均
大户赋值:收盘价/XX的60日指数移动平均
散户赋值:收盘价/XX的120日指数移动平均
底赋值:1
1.02,NODRAW
高赋值:1.03
当满足条件主力上穿1.02时,在收盘价*0.999位置书写文字,画青色
当满足条件主力上穿1.04时,在收盘价位置画24号图标
当满足条件主力上穿1.04时,在收盘价*0.999位置书写文字,画淡洋红色
A1赋值:(成交量(手)/收盘价)/3
A2赋值:(如果((A1>40)AND(收盘价>(1日前的收盘价))),返回A1,否则返回0)的历史累和
A3赋值:(如果((A1>40)AND(收盘价<(1日前的收盘价))),返回A1,否则返回0)的历史累和
A4赋值:(如果((A1<40)AND(收盘价>(1日前的收盘价))),返回A1,否则返回0)的历史累和
A5赋值:(如果((A1<40)AND(收盘价<(1日前的收盘价))),返回A1,否则返回0)的历史累和
A6赋值:((A2+A3)+A4)+A5
A7赋值:如果(数据位置状态=2),返回((100*A2)/A6),否则返回0
A8赋值:((如果(数据位置状态=2),返回((100*A3)/A6),否则返回0))
A9赋值:((如果(数据位置状态=2),返回((100*A4)/A6),否则返回0))
A10赋值:((如果(数据位置状态=2),返回((100*A5)/A6),否则返回0))
机构买盘赋值:(A2),线宽为2
机构卖盘赋值:(A3),线宽为2
散户买盘赋值:(A4)
散户卖盘赋值:(A5)
当满足条件1时,在横轴0.000纵轴1-0.05位置书写文字,画红色
当满足条件1时,在横轴0.250纵轴1-0.05位置书写文字,COLOR00FF00
当满足条件1时,在横轴0.500纵轴1-0.05位置书写文字,画红色
当满足条件1时,在横轴0.745纵轴1-0.05位置书写文字,COLOR00FF00
H1赋值:前收盘价和最高的较大值
L1赋值:前收盘价和最低的较小值
P1赋值:H1-L1
阻力赋值:L1+P1*7/8,画绿色
支撑赋值:L1+P1*0.5/8,画洋红色
当满足条件支撑小于收盘价保持2个交易日后交叉上穿时,在收盘价位置书写文字,画黄色
当满足条件收盘价小于阻力保持2个交易日后交叉上穿时,在收盘价位置书写文字,画绿色
量价赋值:(成交量(手)/收盘价)/3
B2赋值:(如果((量价>0.20)AND(收盘价>(1日前的收盘价))),返回量价,否则返回0)的历史累和
B3赋值:(如果((量价>0.20)AND(收盘价<(1日前的收盘价))),返回量价,否则返回0)的历史累和
B6赋值:B2+B3
DD1赋值:1
比赋值:B2/B3
BBB1赋值:字符串相加
BBB2赋值:字符串相加
BBB3赋值:字符串相加
当满足条件DD1=1时,在横轴0纵轴0.70位置书写文字,画红色
当满足条件DD1=1时,在横轴0纵轴0.75位置书写文字,画绿色
当满足条件DD1=1时,在横轴0纵轴0.80位置书写文字,COLOR00FFFF

  更多股票公式相关资讯请关注TOU金融网  
关键词:赋值收盘返回攻击资金

上一篇:同花顺洗盘结束选股股票指标公式

下一篇:价值选股公式

声明本站分享的文章旨在促进信息交流,不以盈利为目的,本文观点与本站立场无关,不承担任何责任。部分内容文章及图片来自互联网或自媒体,版权归属于原作者,不保证该信息的准确性,原创性等,如涉及版权等问题,请及时联系我们,本站将在第一时间处理。未经证实的信息仅供参考,不做任何投资和交易根据,据此操作风险自担。本站拥有对此声明的最终解释权。

版权保护:TOU金融资讯提示转载请保留链接: http://www.hnlytg.com/gjs/92860.html

资讯栏目

400-123-1234

联系热线

关注我们

扫描二维码,关注织梦返佣网官方微信,了解更多资讯动态。
新浪微博添加关注
Top
长按图片 添加微信公众号